Re: routing unter ECS 1.1

von Boris Kirkorowicz » Mittwoch, 3. September 2003



Hallo,

ToM schrieb:
> wie, oder was muss ich einstellen, wenn ich mit einer OS/2 workstation
> per LAN ins Internet möchte??
> Ich habe den Standert Gateway unter TCP/IP eingestellt, ich kann auch
> den router anpingen 192.168.1.1 aber ich komme nicht ins Internet?!?!?
> Hat jemand ein TiP??

So viele, das paßt gar nicht in ein einziges Posting. Grenzen wir die
Sache doch mal ein wenig ein: poste als erstes doch mal Deine
\MPTN\BIN\SETUP.CMD und die Ausgabe von
netstat -ra > netstat.txt


Gruss Greetings
Boris Kirkorowicz

--
Mail im HTML-Format wird nicht gelesen. Die Adresse gilt bis 30.9.03
Danach bitte das Formular unter http://www.kirk.de/mail.shtml nutzen.
eMail containing HTML will not be read. This address expires 30 Sep 03.
After this date, use the form at http://www.kirk.de/mail.shtml




Re: routing unter ECS 1.1

von The Real OS/2 Guy » Donnerstag, 4. September 2003







DAS ist schlicht nicht möglich. LAN und Internet sind 2 ganz
verschiedene Paar Stiefel.


Nope. Poste mal:
\mptn\bin\setup.cmd
\mptn\etc\resolv2
\mptn\etc\hosts

und vom Router:
\mptn\bin\setup.cmd
\mptn\etc\resolv2
\mptn\etc\hosts

Was hast Du auf dem als Dialer installiert? Kann der Router selbst ins
Inernet?
Die Einstellungen von dem wären auch interessant.

--
Tschau/Bye
Herbert

eComStation 1.1 Deutsch Beta ist verügbar



Re: routing unter ECS 1.1

von tomdet » Samstag, 6. September 2003



Hallo Boris,

das Routing wird optional von ein Rechner gehändelt (Linux Suse 8.1 oder Win xp)

die netstat:

Ach ja standert gateway ist die "192.168.0.1" nicht klar ist für mich warum die
192.168.0.2 unter router mit drin steht?? das ist die IP von OS/2 client.

********************************

destination router netmask metric flags intrf

127.0.0.1 127.0.0.1 255.255.255.255 0 UH lo
192.168 192.168.0.2 255.255.255.0 0 UC lan0
192.168 192.168.0.1 255.255.255.0 1 UGSP lan0
addr 127.0.0.1 Interface 9 mask 0xff000000 broadcast 127.0.0.1
Multicast addrs:
224.0.0.1

addr 192.168.0.2 Interface 0 mask 0xffffff00 broadcast 192.168.0.255
Multicast addrs:
224.0.0.1


*******************************

setup.cmd:

*******************************
route -fh
arp -f
ifconfig lo 127.0.0.1
ifconfig lan0 192.168.0.2 netmask 255.255.255.0 metric 1 mtu 1500
REM ifconfig lan1 metric 1 mtu 1500
REM ifconfig lan2 metric 1 mtu 1500
REM ifconfig lan3 metric 1 mtu 1500
REM ifconfig lan4 metric 1 mtu 1500
REM ifconfig lan5 metric 1 mtu 1500
REM ifconfig lan6 metric 1 mtu 1500
REM ifconfig lan7 metric 1 mtu 1500
REM ifconfig sl0
route add -net 192.168.0.1 192.168.0.1 -netmask 255.255.255.0 -hopcount 1
ipgate off
*************************************

danke für die Hilfe

liebe Grüsse


ToM ;)








Re: routing unter ECS 1.1

von Klaus Dobbrick » Samstag, 6. September 2003



Hallo ToM,




Du schriebst, Dein Router hätte die IP 192.168.1.1. Dann sollte hier auch
die Adresse auftauchen. Versuch es mal mit: "route add -net default
192.168.1.1". Vielleicht noch: "ipgate on". Ob das im LAN allerdings
zwingend ist, weiss ich nicht.

Gruss, Klaus




Re: routing unter ECS 1.1

von Boris Kirkorowicz » Samstag, 6. September 2003



Hallo,



Nur für den Router: es schaltet die Weiterleitung ein.



Gruss Greetings
Boris Kirkorowicz

--
Mail im HTML-Format wird nicht gelesen. Die Adresse gilt bis 30.9.03
Danach bitte das Formular unter http://www.kirk.de/mail.shtml nutzen.
eMail containing HTML will not be read. This address expires 30 Sep 03.
After this date, use the form at http://www.kirk.de/mail.shtml 




Re: routing unter ECS 1.1

von tomdet » Sonntag, 7. September 2003



Hallo Klaus,


Er hatte die 1.1 / jetzt hat er die 0.1 das ist auch so gewollt!!
nur ist mir nicht klar wo das problem liegt!! ping zu den Linux Server
ist kein problem, aber mehr passiert auch nicht.. die Linux u. Windows
Client's kommen alle über den Standet Gateway ins Internet..


Sorry ist ein Missverständniss!! Ich hatte noch andere Problme gehabt,
die jetzt aber nicht zur Sache gehören die Router hat die IP
192.168.0.1


Liebe Grüsse

Tom ;)



Re: routing unter ECS 1.1

von tomdet » Sonntag, 7. September 2003



Hallo Boris,




Wie jetzt muss die Weiterleitung beim OS/2 client aktiviert werden??

Ich möchte wie schon beschreiben, mit ein ECS OS2 client über ein
DSL/Server ins internet! Dort ist Linux installiert welches das
"forward routing" übernimmt.. Und als 192.168.0.1 Gateway eingestellt
ist..

OS2 hat die IP. 192.168.0.2

Ich komme sonst mit allen anderen Rechnern, wo kein ECS installiert
ist ins Internet..


Liebe grüsse

ToM ;)



Re: routing unter ECS 1.1

von Boris Kirkorowicz » Sonntag, 7. September 2003



Hallo ToM,



Nein.
Wie ich schrieb, ist es für die Weiterleitung wichtig; Dein Client
leitet aber nichts weiter, da er nicht gleichzeitig auch Router ist.



Gruss Greetings
Boris Kirkorowicz

--
Mail im HTML-Format wird nicht gelesen. Die Adresse gilt bis 30.9.03
Danach bitte das Formular unter http://www.kirk.de/mail.shtml nutzen.
eMail containing HTML will not be read. This address expires 30 Sep 03.
After this date, use the form at http://www.kirk.de/mail.shtml 




Re: routing unter ECS 1.1

von Boris Kirkorowicz » Sonntag, 7. September 2003



Hallo ToM,



Dennoch fehlt die Default-Route. So wie es im Augenblick ist, routet er
nur im eigenen (privaten) Subnetz, was im Grunde überflüssig ist. Deine
SETUP.CMD sollte also so aussehen:
==============================SCHNIPP==============================
route -fh
arp -f
ifconfig lo 127.0.0.1
ifconfig lan0 192.168.0.2 netmask 255.255.255.0 metric 0 mtu 1492
REM ifconfig lan1
REM ifconfig lan2
REM ifconfig lan3
REM ifconfig lan4
REM ifconfig lan5
REM ifconfig lan6
REM ifconfig lan7
REM ifconfig sl0
route add default 192.168.0.1 -hopcount 1
route add -net 192.168 192.168.0.1 -hopcount 1
ipgate off
==============================SCHNAPP==============================

Probier's mal aus und berichte.



Gruss Greetings
Boris Kirkorowicz

--
Mail im HTML-Format wird nicht gelesen. Die Adresse gilt bis 30.9.03
Danach bitte das Formular unter http://www.kirk.de/mail.shtml nutzen.
eMail containing HTML will not be read. This address expires 30 Sep 03.
After this date, use the form at http://www.kirk.de/mail.shtml 




Re: routing unter ECS 1.1

von Klaus Dobbrick » Sonntag, 7. September 2003



Hallo ToM,




ok.


Du brauchst aber eine Default Route, sonst funktioniert das nicht. Ich gehe
hier auch über Linux ins Internet. Die Default Route zeigt hier auf den
Linux-Server, der dann das Weitere übernimmt. Also route add -net default
192.168.0.1. Ausserdem fällt mir gerade auf, dass Dein Routingeintrag auf
sich selber zeigt. Schon aufgefallen?

Gruss, Klaus




Re: routing unter ECS 1.1

von tomdet » Sonntag, 7. September 2003



Hallo Boris,





Ich habe schönes zu berichten, es läuft jetzt...
Ich hatte die setup.cmd
angepasst, aber leider wollte es immer noch nicht so richtig funzeln,
bis ich dann gesehen hatte, dass ich den DNS ja gar nicht eingetragen
hatte :(!! "Dau" lässt grüssen ;) Eingetragen, und nun ist allet supi
;))


Besten Dank und allerliebste Grüsse

auch an Klaus..

ToM ;)



If you have any questions, you can contact us: admin#mofeel.net     Spam Report